智表说明

各位尊敬的朋友：

首先感谢您对智表（ZCELL）的使用。智表致力于在浏览器端为您提供Excel般的操作体验，让您的表格智能起来！

经过智表研发团队的不懈努力，智表（ZCELL）V1.0.0.1 版终于跟大家见面啦！真诚欢迎您的使用，盼望得到您宝贵的意见和支持，只有您的支持，我们才能以强大的技术开发力量继续进行产品升级，不断满足日益复杂的场景要求。我们非常希望您能与我们一起，将智表（ZCELL）做的更好、更强、更完善。

在智表（ZCELL）产品的编写过程中，我们亟需您最真实的意见，请发送邮件到108653210@qq.com或联系QQ108653210（请注明智表咨询），不论是表扬还是批评，是您的需求还是建议，您的关注就是我们前进的动力，来吧，朋友，让我们一起把智表做的更好、更强大。


ZCell

方法：

ZCell（outcontainer）

功能描述：

通过New一个实例，创建一个新的智表对象。严格来讲这个不算是方法，为了统一放在一起说明。

参数：

outcontainer   外部容器

样例：

在id=”cellContainer”的DIV里创建一个ZCELL对象
var zcell1 = new ZCell(document.getElementById("cellContainer"));


InserSheet

方法：

InserSheet (index, row, col)

功能描述：

在指定的位置，创建一个指定行数和列数的表页。

参数：

index  位置索引，从0开始
row  行数
col  列数

样例：

在zcell1里索引0的位置里创建一个5行5列的表

zcell1.InserSheet(0,5,5);


GetSheet

方法：

GetSheet (index)

功能描述：

获取指定位置的表对象。

参数：

index  位置索引，从0开始

返回值：

表对象。

样例：

获取zcell1里索引0的表对象

var sheet1 = zcell1.GetSheet(0);


ShowColLab

方法：

ShowColLab (flag)

功能描述：

设置列标尺是否显示。

参数：

flag  显示标志，1： 显示   0：隐藏

样例：

设置表列标隐藏

zcell1.GetSheet(0).ShowColLab(0);


ShowRowLab

方法：

ShowRowLab (flag)

功能描述：

设置行标尺是否显示。

参数：

flag  显示标志，1： 显示   0：隐藏

样例：

设置表行标隐藏

zcell1.GetSheet(0).ShowRowLab(0);


SetColWidth

方法：

SetColWidth (index, val)

功能描述：

设置指定列的宽度。

参数：

Index  列的索引号，从0开始。
val    宽度的像素值。

样例：

设置第4列列宽250px

zcell1.GetSheet(0).SetColWidth(3,250);


SetRowHeight

方法：

SetRowHeight (index, val)

功能描述：

设置指定行的高度。

参数：

index  行的索引号，从0开始。
val    高度的像素值。

样例：

设置第4行行高度150px

zcell1.GetSheet(0).SetRowHeight(3,150);


GetCell

方法：

GetCell (rowIndex, colIndex)

功能描述：

获取指定单元格对象。

参数：

rowIndex   行的索引号，从0开始。
colIndex   列的索引号，从0开始。

样例：

获取第3行第4列单元格对象

var c1 = zcell1.GetSheet(0). GetCell (2,3);


SetCellString

方法：

SetCellString (rowIndex, colIndex, val)

功能描述：

设置指定单元格的文本值。

参数：

rowIndex   行的索引号，从0开始。
colIndex   列的索引号，从0开始。
val        新的文本值。

样例：

设置第3行第3列单元格文本值为”我是新的单元格文本值”

zcell1.GetSheet(0).SetCellString(2,2,"我是新的单元格文本值");


GetCellString

方法：

GetCellString (rowIndex, colIndex)

功能描述：

获取指定单元格的文本值。

参数：

rowIndex   行的索引号，从0开始。
colIndex   列的索引号，从0开始。

样例：

获取第3行第3列单元格文本值

var val1 = zcell1.GetSheet(0).GetCellString(2,2)


SetCellStyle

方法：

SetCellStyle (rowIndex, colIndex, val)

功能描述：

设置指定单元格的样式值。

参数：

rowIndex   行的索引号，从0开始。
colIndex   列的索引号，从0开始。
val        样式值，按JQUERY格式要求。

样例：

设置第4行第4列单元格背景色和文本对齐方式：

var style =  {

        "background-color":"yellow",

        "text-align":"left"

 };

zcell1.GetSheet(0).SetCellStyle(3,3,style);


LoadJsonData

方法：

LoadJsonData (jsondata)

功能描述：

将json串数据加载到表内。

参数：

jsondata  json格式的数据串。

样例：

设置第4行第4列单元格背景色和文本对齐方式：

var jsondata = [
    ["年度", "列1", "列2"],

    ["2016", 11111, 2],

    ["2017", 22222, 5]
];

zcell1.GetSheet(0).LoadJsonData(jsondata);


GetDataJson

方法：

GetDataJson ()

功能描述：

获取当前表的数据，转换为json串数据。

返回值：

json串数据。

样例：

获取第1个表页的json数据：

var datastr = zcell1.GetSheet(0).GetDataJson();